CVE-2026-11572 degit has a Command Injection issue
An attacker can execute arbitrary OS commands by supplying a crafted git repository name to the degit library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-11572?
CVE-2026-11572 is a high-severity command injection vulnerability in degit, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Versions of the package degit before 2.8.6, from 3.0.0 and before 3.3.1 are vulnerable to Command Injection due to improper sanitisation of user input for git shell commands directly invoked with exec() method by _cloneWithGit() and fetchRefs() functions. An attacker can execute arbitrary operating system commands as the process user by supplying a specially crafted git repository name.
Which versions are affected by CVE-2026-11572?
4 open source packages ship an affected version, including degit.
| Package | Affected | Fixed in |
|---|---|---|
degit npm | All versions | 2.8.6 |
degit npm | All versions | 2.8.6 |
degit npm | From 3.0.0 | 3.3.1 |
degit npm | From 3.0.0 | 3.3.1 |
How do I fix CVE-2026-11572?
Upgrade degit to a fixed version for your release line: 2.8.6 or 3.3.1.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2026-11572 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-11572 exists.
Sources
Also known as GHSA-77c7-pq4r-6mcq.