# CVE-2026-11572: degit has a Command Injection issue

> An attacker can execute arbitrary OS commands by supplying a crafted git repository name to the degit library.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Jun 2026
- **Updated:** 9 Jun 2026
- **Also known as:** GHSA-77c7-pq4r-6mcq

## What is CVE-2026-11572?

CVE-2026-11572 is a high-severity command injection vulnerability in degit, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Versions of the package degit before 2.8.6, from 3.0.0 and before 3.3.1 are vulnerable to Command Injection due to improper sanitisation of user input for git shell commands directly invoked with exec() method by _cloneWithGit() and fetchRefs() functions. An attacker can execute arbitrary operating system commands as the process user by supplying a specially crafted git repository name.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command), CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-11572?

4 open source packages ship an affected version, including degit.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `degit` | npm | All versions | 2.8.6 |
| `degit` | npm | All versions | 2.8.6 |
| `degit` | npm | From 3.0.0 | 3.3.1 |
| `degit` | npm | From 3.0.0 | 3.3.1 |

## How do I fix CVE-2026-11572?

Upgrade degit to a fixed version for your release line: 2.8.6 or 3.3.1.

## Is CVE-2026-11572 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-11572 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-11572 and fix it if it is affected.

What it is: CVE-2026-11572 is a high-severity command injection vulnerability in degit, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-11572 exists.

Affected packages and fixed versions:
- degit (npm): affected all versions; fixed in 2.8.6
- degit (npm): affected all versions; fixed in 2.8.6
- degit (npm): affected from 3.0.0; fixed in 3.3.1
- degit (npm): affected from 3.0.0; fixed in 3.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-11572/ (Markdown: https://insights.sbomify.com/CVE-2026-11572/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-11572
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-11572
- OSV: https://osv.dev/vulnerability/CVE-2026-11572

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-11572/
Summaries are generated and may contain mistakes; the official description above is the record.
