# CVE-2026-115730: i18next-http-backend 4.0.2 Protocol-Relative URL Injection via Namespace in interpolateUrl


- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-9jhj-wvmw-cfx5, UBUNTU-CVE-2026-115730

## What is CVE-2026-115730?

CVE-2026-115730 is a low-severity vulnerability in i18next-http-backend, published on 23 Oct 2026. 

### Official description

i18next-http-backend 4.0.2 contains an incomplete fix in interpolateUrl() that allows attackers to redirect translation requests by supplying an ns value starting with a slash. Attackers controlling the namespace value can form a protocol-relative URL in loadPath or addPath templates to load attacker-hosted translations, enabling UI content injection and cross-site scripting.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2026-115730?

2 open source packages ship an affected version, including i18next-http-backend.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `i18next-http-backend` | npm | All versions | 4.0.3 |
| `i18next-http-backend` | npm | All versions | 4.0.3 |

## How do I fix CVE-2026-115730?

Upgrade i18next-http-backend to 4.0.3 or later.

## Is CVE-2026-115730 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-115730 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115730 and fix it if it is affected.

What it is: CVE-2026-115730 is a low-severity vulnerability in i18next-http-backend, published on 23 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-115730 exists.

Affected packages and fixed versions:
- i18next-http-backend (npm): affected all versions; fixed in 4.0.3
- i18next-http-backend (npm): affected all versions; fixed in 4.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115730/ (Markdown: https://insights.sbomify.com/CVE-2026-115730/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115730
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115730
- OSV: https://osv.dev/vulnerability/CVE-2026-115730

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115730/
Summaries are generated and may contain mistakes; the official description above is the record.
