# CVE-2026-115774: Twisted: Denial of Service in the Twisted IMAP4 Server via a Negative Literal Size in SEARCH


- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** AZL-111416, DEBIAN-CVE-2026-115774, ECHO-f150-d773-3934, GHSA-2qrf-pqgx-qh9v, UBUNTU-CVE-2026-115774

## What is CVE-2026-115774?

CVE-2026-115774 is a medium-severity vulnerability in twisted, published on 23 Oct 2026. 

### Official description

Twisted is an event-based framework for internet applications, supporting Python 3.6+. Prior to 26.10.0rc1, twisted.mail.imap4.IMAP4Server reaches twisted.mail.imap4.parseNestedParens with a negative literal size in an authenticated SEARCH command after the client enters the selected mailbox state. The negative size moves the parser cursor below zero, and Python's negative indexing prevents the synchronous scanning loop from terminating. The loop freezes the single-threaded reactor, stopping other IMAP connections and any SMTP or POP3 services hosted in the same process until restart. This issue is fixed in version 26.10.0rc1.

Weakness: CWE-835 (Loop with Unreachable Exit Condition), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-115774?

2 open source packages ship an affected version, including Twisted and twisted.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Twisted` | PyPI | All versions | 26.10.0rc1 |
| `twisted` | PyPI | All versions | 26.10.0rc1 |

## How do I fix CVE-2026-115774?

Upgrade Twisted to 26.10.0rc1 or later.

## Is CVE-2026-115774 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-115774 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115774 and fix it if it is affected.

What it is: CVE-2026-115774 is a medium-severity vulnerability in twisted, published on 23 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-115774 exists.

Affected packages and fixed versions:
- Twisted (PyPI): affected all versions; fixed in 26.10.0rc1
- twisted (PyPI): affected all versions; fixed in 26.10.0rc1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115774/ (Markdown: https://insights.sbomify.com/CVE-2026-115774/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115774
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115774
- OSV: https://osv.dev/vulnerability/CVE-2026-115774

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115774/
Summaries are generated and may contain mistakes; the official description above is the record.
