# CVE-2026-115775: Twisted: Unauthenticated Remote Denial of Service in the Twisted words domish XML Element Stream via an Unbounded Element Tree


- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** AZL-111422, DEBIAN-CVE-2026-115775, ECHO-6041-69ad-171d, GHSA-3476-c5c2-fr73, UBUNTU-CVE-2026-115775

## What is CVE-2026-115775?

CVE-2026-115775 is a high-severity vulnerability in twisted, published on 23 Oct 2026. 

### Official description

Twisted is an event-based framework for internet applications, supporting Python 3.6+. Prior to 26.10.0rc1, the twisted.words.xish.domish ExpatElementStream parser allows an unauthenticated remote peer to keep a container element open while continuously adding child elements. The parser retains the unfinished stanza as an in-memory tree without a byte or element-count limit, and XMPP pre-authentication stream parsing exposes this behavior before credentials are accepted. A single connection can therefore exhaust server memory and terminate the process. This issue is fixed in version 26.10.0rc1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-115775?

2 open source packages ship an affected version, including Twisted and twisted.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Twisted` | PyPI | All versions | 26.10.0rc1 |
| `twisted` | PyPI | All versions | 26.10.0rc1 |

## How do I fix CVE-2026-115775?

Upgrade Twisted to 26.10.0rc1 or later.

## Is CVE-2026-115775 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-115775 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115775 and fix it if it is affected.

What it is: CVE-2026-115775 is a high-severity vulnerability in twisted, published on 23 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-115775 exists.

Affected packages and fixed versions:
- Twisted (PyPI): affected all versions; fixed in 26.10.0rc1
- twisted (PyPI): affected all versions; fixed in 26.10.0rc1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115775/ (Markdown: https://insights.sbomify.com/CVE-2026-115775/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115775
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115775
- OSV: https://osv.dev/vulnerability/CVE-2026-115775

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115775/
Summaries are generated and may contain mistakes; the official description above is the record.
