# CVE-2026-115776: Twisted: Unauthenticated Remote Denial of Service in the Twisted IRC Server via an Unbounded Line Buffer


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** AZL-111410, DEBIAN-CVE-2026-115776, ECHO-988d-d5ce-c91c, GHSA-53xc-49m8-p798, UBUNTU-CVE-2026-115776

## What is CVE-2026-115776?

CVE-2026-115776 is a high-severity vulnerability in twisted, published on 23 Oct 2026. 

### Official description

Twisted is an event-based framework for internet applications, supporting Python 3.6+. Prior to 26.10.0rc1, twisted.words.protocols.irc.IRC.dataReceived retains all bytes received without a line feed in its per-connection buffer and applies no maximum line length. The twisted.words.service.IRCUser server subclass inherits this behavior, and buffering occurs before PASS, NICK, or USER authentication commands. An unauthenticated connection can continuously grow the buffer until the shared server process runs out of memory and drops all users. This issue is fixed in version 26.10.0rc1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-115776?

2 open source packages ship an affected version, including Twisted and twisted.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Twisted` | PyPI | All versions | 26.10.0rc1 |
| `twisted` | PyPI | All versions | 26.10.0rc1 |

## How do I fix CVE-2026-115776?

Upgrade Twisted to 26.10.0rc1 or later.

## Is CVE-2026-115776 being exploited?

There is no known exploitation of CVE-2026-115776 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115776 and fix it if it is affected.

What it is: CVE-2026-115776 is a high-severity vulnerability in twisted, published on 23 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115776 in the wild and no public exploit code.

Affected packages and fixed versions:
- Twisted (PyPI): affected all versions; fixed in 26.10.0rc1
- twisted (PyPI): affected all versions; fixed in 26.10.0rc1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115776/ (Markdown: https://insights.sbomify.com/CVE-2026-115776/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115776
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115776
- OSV: https://osv.dev/vulnerability/CVE-2026-115776

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115776/
Summaries are generated and may contain mistakes; the official description above is the record.
