# CVE-2026-115778: Twisted: Unauthenticated Remote Denial of Service in the Twisted conch Telnet Transport via an Unbounded Subnegotiation Buffer


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** AZL-111413, DEBIAN-CVE-2026-115778, ECHO-27c0-b1bd-95d4, GHSA-cwm5-jh59-mwxr, UBUNTU-CVE-2026-115778

## What is CVE-2026-115778?

CVE-2026-115778 is a high-severity vulnerability in twisted, published on 23 Oct 2026. 

### Official description

Twisted is an event-based framework for internet applications, supporting Python 3.6+. Prior to 26.10.0rc1, twisted.conch.telnet.Telnet.dataReceived appends every byte received after IAC SB to a persistent subnegotiation buffer until IAC SE is received, without applying a maximum length. Telnet option negotiation occurs before authentication, so an unauthenticated peer can omit the terminator and continuously grow the buffer. The resulting memory exhaustion can terminate the process and every service it hosts. This issue is fixed in version 26.10.0rc1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-115778?

2 open source packages ship an affected version, including Twisted and twisted.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Twisted` | PyPI | All versions | 26.10.0rc1 |
| `twisted` | PyPI | All versions | 26.10.0rc1 |

## How do I fix CVE-2026-115778?

Upgrade Twisted to 26.10.0rc1 or later.

## Is CVE-2026-115778 being exploited?

There is no known exploitation of CVE-2026-115778 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115778 and fix it if it is affected.

What it is: CVE-2026-115778 is a high-severity vulnerability in twisted, published on 23 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115778 in the wild and no public exploit code.

Affected packages and fixed versions:
- Twisted (PyPI): affected all versions; fixed in 26.10.0rc1
- twisted (PyPI): affected all versions; fixed in 26.10.0rc1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115778/ (Markdown: https://insights.sbomify.com/CVE-2026-115778/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115778
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115778
- OSV: https://osv.dev/vulnerability/CVE-2026-115778

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115778/
Summaries are generated and may contain mistakes; the official description above is the record.
