# CVE-2026-115877: Twisted: HTTP Request Smuggling in twisted.web via a Bare CR or LF in a Header Value


- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** AZL-111407, DEBIAN-CVE-2026-115877, ECHO-73bd-6fda-55fe, GHSA-q7qq-6mhp-9rc4, UBUNTU-CVE-2026-115877

## What is CVE-2026-115877?

CVE-2026-115877 is a medium-severity vulnerability in twisted, published on 23 Oct 2026. 

### Official description

Twisted is an event-based framework for internet applications, supporting Python 3.6+. Prior to 26.10.0rc1, twisted.web.http.HTTPChannel.headerReceived rejects a NUL byte in an HTTP header value but accepts a bare carriage return or bare line feed. Because Twisted splits header lines only on CRLF, a hidden Content-Length header can remain folded into another value while a lenient front end treats the bare character as a line terminator. The resulting framing disagreement can smuggle a following request past front-end access controls, poison a shared connection or cache, and expose a later client to the wrong response. This issue is an incomplete-fix residual of earlier Twisted request-smuggling protections. This issue is fixed in version 26.10.0rc1.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2026-115877?

2 open source packages ship an affected version, including Twisted and twisted.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Twisted` | PyPI | All versions | 26.10.0rc1 |
| `twisted` | PyPI | All versions | 26.10.0rc1 |

## How do I fix CVE-2026-115877?

Upgrade Twisted to 26.10.0rc1 or later.

## Is CVE-2026-115877 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-115877 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115877 and fix it if it is affected.

What it is: CVE-2026-115877 is a medium-severity vulnerability in twisted, published on 23 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-115877 exists.

Affected packages and fixed versions:
- Twisted (PyPI): affected all versions; fixed in 26.10.0rc1
- twisted (PyPI): affected all versions; fixed in 26.10.0rc1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115877/ (Markdown: https://insights.sbomify.com/CVE-2026-115877/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115877
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115877
- OSV: https://osv.dev/vulnerability/CVE-2026-115877

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115877/
Summaries are generated and may contain mistakes; the official description above is the record.
