# CVE-2026-115885: LangGraph CLI prints the registry push token in `langgraph deploy --verbose` output


- **Severity:** Medium 4.1 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-8prr-f582-jqq3

## What is CVE-2026-115885?

CVE-2026-115885 is a medium-severity vulnerability in langchain-ai langgraph, published on 23 Oct 2026. 

### Official description

The LangGraph CLI is the official command-line interface for LangGraph. From 0.4.15 until 0.4.32, langgraph deploy --verbose passes a temporary registry push token on standard input to docker login --password-stdin, but the CLI subprocess helper prints command input in verbose mode. Anyone who can read resulting CI logs or terminal recordings before the token's maximum 12-hour expiration can pull deployment images or push images to that deployment's image repository. Deployments without --verbose and remote image builds are not affected, and the token alone cannot update a deployment to execute a pushed image. This issue is fixed in version 0.4.32.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2026-115885?

2 open source packages ship an affected version, including langgraph-cli.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langgraph-cli` | PyPI | From 0.4.15 | 0.4.32 |
| `langgraph-cli` | PyPI | From 0.4.15 | 0.4.32 |

## How do I fix CVE-2026-115885?

Upgrade langgraph-cli to 0.4.32 or later.

## Is CVE-2026-115885 being exploited?

There is no known exploitation of CVE-2026-115885 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115885 and fix it if it is affected.

What it is: CVE-2026-115885 is a medium-severity vulnerability in langchain-ai langgraph, published on 23 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115885 in the wild and no public exploit code.

Affected packages and fixed versions:
- langgraph-cli (PyPI): affected from 0.4.15; fixed in 0.4.32
- langgraph-cli (PyPI): affected from 0.4.15; fixed in 0.4.32

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115885/ (Markdown: https://insights.sbomify.com/CVE-2026-115885/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115885
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115885
- OSV: https://osv.dev/vulnerability/CVE-2026-115885

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115885/
Summaries are generated and may contain mistakes; the official description above is the record.
