# CVE-2026-115906: zip: AES Entry HMAC Authentication Bypass on Premature EOF


- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-115906, GHSA-8hxf-qr8p-62x4, UBUNTU-CVE-2026-115906

## What is CVE-2026-115906?

CVE-2026-115906 is a medium-severity vulnerability in zip-rs zip2, published on 26 Oct 2026. 

### Official description

zip is a zip library for Rust that supports reading and writing simple ZIP files. From 0.6.0 until 9.0.0, the AES entry reader in src/aes.rs verifies its HMAC only when the attacker-controlled data counter reaches zero. If the underlying bounded reader reaches the real end of the archive while data_remaining is still positive, or if an encrypted entry has no payload, the reader can return a clean end of stream without reading and comparing the authentication tag. Applications using by_index_decrypt, by_name_decrypt, by_path_decrypt, or password-enabled by_index_with_options can therefore accept modified plaintext without an authentication error. This issue is fixed in version 9.0.0.

Weakness: CWE-354 (Improper Validation of Integrity Check Value), CWE-1284 (Improper Validation of Specified Quantity in Input)

## Which versions are affected by CVE-2026-115906?

2 open source packages ship an affected version, including zip.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zip` | crates.io | From 0.6.0 | 9.0.0 |
| `zip` | crates.io | From 0.6.0 | 9.0.0 |

## How do I fix CVE-2026-115906?

Upgrade zip to 9.0.0 or later.

## Is CVE-2026-115906 being exploited?

There is no known exploitation of CVE-2026-115906 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115906 and fix it if it is affected.

What it is: CVE-2026-115906 is a medium-severity vulnerability in zip-rs zip2, published on 26 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115906 in the wild and no public exploit code.

Affected packages and fixed versions:
- zip (crates.io): affected from 0.6.0; fixed in 9.0.0
- zip (crates.io): affected from 0.6.0; fixed in 9.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115906/ (Markdown: https://insights.sbomify.com/CVE-2026-115906/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115906
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115906
- OSV: https://osv.dev/vulnerability/CVE-2026-115906

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115906/
Summaries are generated and may contain mistakes; the official description above is the record.
