# CVE-2026-115907: zip: legacy Shrink/Reduce/Implode decoder: denial of service from attacker-controlled ZIP64 uncompressed size


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-115907, GHSA-9hj8-73fh-9963, UBUNTU-CVE-2026-115907

## What is CVE-2026-115907?

CVE-2026-115907 is a high-severity vulnerability in zip-rs zip2, published on 26 Oct 2026. 

### Official description

zip is a zip library for Rust that supports reading and writing simple ZIP files. From 5.1.0 until 9.0.0, applications built with the legacy-zip feature can reserve output capacity from an attacker-controlled ZIP64 uncompressed size before validating the compressed stream. The ShrinkDecoder path in src/legacy/shrink.rs can panic with a capacity overflow during ZipArchive::extract, and the Reduce and Implode decoders contain the same unbounded preallocation pattern. An unhandled panic can terminate an archive-processing service. This issue is fixed in version 9.0.0.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-115907?

2 open source packages ship an affected version, including zip.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zip` | crates.io | From 5.1.0 | 9.0.0 |
| `zip` | crates.io | From 5.1.0 | 9.0.0 |

## How do I fix CVE-2026-115907?

Upgrade zip to 9.0.0 or later.

## Is CVE-2026-115907 being exploited?

There is no known exploitation of CVE-2026-115907 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115907 and fix it if it is affected.

What it is: CVE-2026-115907 is a high-severity vulnerability in zip-rs zip2, published on 26 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115907 in the wild and no public exploit code.

Affected packages and fixed versions:
- zip (crates.io): affected from 5.1.0; fixed in 9.0.0
- zip (crates.io): affected from 5.1.0; fixed in 9.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115907/ (Markdown: https://insights.sbomify.com/CVE-2026-115907/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115907
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115907
- OSV: https://osv.dev/vulnerability/CVE-2026-115907

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115907/
Summaries are generated and may contain mistakes; the official description above is the record.
