# CVE-2026-115911: vLLM: DoS via unbounded chat_template Jinja2 rendering exhausts the renderer thread pool


- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** GHSA-542m-9234-8gvf, PYSEC-2026-4344

## What is CVE-2026-115911?

CVE-2026-115911 is a medium-severity vulnerability in Vllm Vllm, published on 26 Oct 2026. 

### Official description

vLLM is an inference and serving engine for large language models. From 0.19.0 until 0.32.0, authenticated callers can supply a request chat template when no server-side --chat-template is configured, or a malicious model repository can provide a template that is compiled and rendered by tokenizer.apply_chat_template() without a wall-clock timeout, output-size limit, or iteration bound. Rendering runs in a ThreadPoolExecutor with one worker by default, so a nonterminating render can block /v1/responses and other chat-template users after the request ends, while an output-expanding render can exhaust server memory. Harmony models are not affected because they do not use this Jinja path. This issue is fixed in version 0.32.0.

Weakness: CWE-834 (Excessive Iteration), CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-115911?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.19.0 | 0.32.0 |
| `vllm` | PyPI | From 0.19.0 | 0.32.0 |
| `vllm` | PyPI | From 0.19.0 | 0.32.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-115911?

Upgrade vllm to 0.32.0 or later.

## Is CVE-2026-115911 being exploited?

There is no known exploitation of CVE-2026-115911 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115911 and fix it if it is affected.

What it is: CVE-2026-115911 is a medium-severity vulnerability in Vllm Vllm, published on 26 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115911 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.19.0; fixed in 0.32.0
- vllm (PyPI): affected from 0.19.0; fixed in 0.32.0
- vllm (PyPI): affected from 0.19.0; fixed in 0.32.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115911/ (Markdown: https://insights.sbomify.com/CVE-2026-115911/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115911
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115911
- OSV: https://osv.dev/vulnerability/CVE-2026-115911

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115911/
Summaries are generated and may contain mistakes; the official description above is the record.
