CVE-2026-115914 vLLM DeepSeek-OCR image processing vulnerable to denial of service

Medium 6.5 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-115914?

CVE-2026-115914 is a medium-severity vulnerability in Vllm Vllm, published on 26 Oct 2026.

Official description

vLLM is an inference and serving engine for large language models. From 0.11.1 until 0.32.0, the DeepSeek-OCR, DeepSeek-OCR-2, and Unlimited-OCR image path allows a remote client that can reach the OpenAI-compatible API to submit a legal image whose normalized pixels sum to zero when that image is alone in its per-step encoder batch. _parse_and_validate_image_input returns no embedding, embed_multimodal propagates that value, and sanity_check_mm_encoder_outputs triggers a fatal assertion that shuts down the engine for all users. This issue is fixed in version 0.32.0.

Weakness: CWE-617

Which versions are affected by CVE-2026-115914?

2 open source packages ship an affected version, including vllm. It affects 1 product.

PackageAffectedFixed in
vllm PyPIFrom 0.11.10.32.0
vllm PyPIFrom 0.11.10.32.0

Products include Vllm Vllm.

How do I fix CVE-2026-115914?

Upgrade vllm to 0.32.0 or later.

Is CVE-2026-115914 being exploited?

There is no known exploitation of CVE-2026-115914 in the wild and no public exploit code.

All Vllm Vllm vulnerabilities

Sources

Also known as GHSA-gq5q-89c7-vhvx.

Is CVE-2026-115914 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free