{"answers":{"affected":"2 open source packages ship an affected version, including vllm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-115914 in the wild and no public exploit code.","fix":"Upgrade vllm to 0.32.0 or later.","what":"CVE-2026-115914 is a medium-severity vulnerability in Vllm Vllm, published on 26 Oct 2026."},"fix_prompt":"Check this codebase for CVE-2026-115914 and fix it if it is affected.\n\nWhat it is: CVE-2026-115914 is a medium-severity vulnerability in Vllm Vllm, published on 26 Oct 2026. \nExploitation: There is no known exploitation of CVE-2026-115914 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vllm (PyPI): affected from 0.11.1; fixed in 0.32.0\n- vllm (PyPI): affected from 0.11.1; fixed in 0.32.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-115914/ (Markdown: https://insights.sbomify.com/CVE-2026-115914/index.md)","id":"CVE-2026-115914","markdown":"https://insights.sbomify.com/CVE-2026-115914/index.md","name":"CVE-2026-115914","record":{"aliases":["GHSA-gq5q-89c7-vhvx"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"vllm","vendor":"vllm"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-617","name":"Reachable Assertion"}],"description":"vLLM is an inference and serving engine for large language models. From 0.11.1 until 0.32.0, the DeepSeek-OCR, DeepSeek-OCR-2, and Unlimited-OCR image path allows a remote client that can reach the OpenAI-compatible API to submit a legal image whose normalized pixels sum to zero when that image is alone in its per-step encoder batch. _parse_and_validate_image_input returns no embedding, embed_multimodal propagates that value, and sanity_check_mm_encoder_outputs triggers a fatal assertion that shuts down the engine for all users. This issue is fixed in version 0.32.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"vLLM DeepSeek-OCR image processing vulnerable to denial of service","id":"CVE-2026-115914","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"vllm:vllm","products":["vllm:vllm"],"type":null,"year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE","id":"CVE-2026-115915"},"packages":[{"ecosystem":"PyPI","fixed":["0.32.0"],"introduced":["0.11.1"],"last_affected":[],"package":"vllm","purl":null,"source":"GHSA-gq5q-89c7-vhvx"},{"ecosystem":"PyPI","fixed":["0.32.0"],"introduced":["0.11.1"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"GHSA-gq5q-89c7-vhvx"}],"prev":{"headline":"vLLM: Phi-4 multimodal audio encoder materializes and retains full attention matrices: a single max-length audio OOM-crashes the vLLM engine","id":"CVE-2026-115913"},"products":["vllm"],"published":"2026-10-26","related":[{"cvss_score":10,"headline":"vLLM Vulnerable to Remote Code Execution via Mooncake Integration","id":"CVE-2025-32444","kev_date_added":null,"published":"2025-04-30"},{"cvss_score":9.8,"headline":"vLLM leaks a heap address when PIL throws an error","id":"CVE-2026-22778","kev_date_added":null,"published":"2026-02-02"},{"cvss_score":9.8,"headline":"vLLM Allows Remote Code Execution via PyNcclPipe Communication Service","id":"CVE-2025-47277","kev_date_added":null,"published":"2025-05-20"},{"cvss_score":9.8,"headline":"Remote Code Execution in vllm-project/vllm","id":"CVE-2024-11041","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.1,"headline":"vLLM: OpenAI auth bypass","id":"CVE-2026-48746","kev_date_added":null,"published":"2026-06-22"},{"cvss_score":9.1,"headline":"vLLM Allows Remote Code Execution via Mooncake Integration","id":"CVE-2025-29783","kev_date_added":null,"published":"2025-03-19"},{"cvss_score":8.8,"headline":"vLLM 0.9.2 before 0.24.0 SSRF via X-Request-Id in P2pNcclConnector","id":"CVE-2026-116176","kev_date_added":null,"published":"2026-10-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2026-10-26","vendors":["vllm-project"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-115914/"}