CVE-2026-115915 vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE

High 8.1 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-115915?

CVE-2026-115915 is a high-severity vulnerability in Vllm Vllm, published on 26 Oct 2026.

Official description

vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.

Weakness: CWE-20, CWE-183

Which versions are affected by CVE-2026-115915?

3 open source packages ship an affected version, including vllm. It affects 1 product.

PackageAffectedFixed in
vllm PyPIAll versions0.32.0
vllm PyPIAll versions0.32.0
vllm PyPIFrom 0.30.00.32.0

Products include Vllm Vllm.

How do I fix CVE-2026-115915?

Upgrade vllm to 0.32.0 or later.

Is CVE-2026-115915 being exploited?

There is no known exploitation of CVE-2026-115915 in the wild and no public exploit code.

All Vllm Vllm vulnerabilities

Sources

Also known as GHSA-h3rc-j82p-2c3h, PYSEC-2026-4346.

Is CVE-2026-115915 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free