# CVE-2026-115915: vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE


- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** GHSA-h3rc-j82p-2c3h, PYSEC-2026-4346

## What is CVE-2026-115915?

CVE-2026-115915 is a high-severity vulnerability in Vllm Vllm, published on 26 Oct 2026. 

### Official description

vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.

Weakness: CWE-20 (Improper Input Validation), CWE-183 (Permissive List of Allowed Inputs)

## Which versions are affected by CVE-2026-115915?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.32.0 |
| `vllm` | PyPI | All versions | 0.32.0 |
| `vllm` | PyPI | From 0.30.0 | 0.32.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-115915?

Upgrade vllm to 0.32.0 or later.

## Is CVE-2026-115915 being exploited?

There is no known exploitation of CVE-2026-115915 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115915 and fix it if it is affected.

What it is: CVE-2026-115915 is a high-severity vulnerability in Vllm Vllm, published on 26 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115915 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.32.0
- vllm (PyPI): affected all versions; fixed in 0.32.0
- vllm (PyPI): affected from 0.30.0; fixed in 0.32.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115915/ (Markdown: https://insights.sbomify.com/CVE-2026-115915/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115915
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115915
- OSV: https://osv.dev/vulnerability/CVE-2026-115915

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115915/
Summaries are generated and may contain mistakes; the official description above is the record.
