# CVE-2026-115917: vLLM: Permissive default CORS origins allow cross-origin requests to the vLLM HTTP server


- **Severity:** Low 3.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** GHSA-vvpg-rrww-wpmh, PYSEC-2026-4348

## What is CVE-2026-115917?

CVE-2026-115917 is a low-severity vulnerability in Vllm Vllm, published on 26 Oct 2026. 

### Official description

vLLM is an inference and serving engine for large language models. Prior to 0.32.0, the OpenAI-compatible server configures Starlette CORSMiddleware with allowed_origins set to a wildcard by default. A malicious web page can use a victim's browser to reach an unauthenticated vLLM server on localhost, an internal network, or a VPN, call endpoints including GET /v1/models and POST /v1/chat/completions, consume GPU resources, and read responses. Cookie-based cross-site request forgery does not apply because credentials are disabled by default, and deployments requiring bearer authentication are exposed only when the caller already has a usable token. This issue is fixed in version 0.32.0.

Weakness: CWE-942 (Permissive Cross-domain Security Policy with Untrusted Domains)

## Which versions are affected by CVE-2026-115917?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.32.0 |
| `vllm` | PyPI | All versions | 0.32.0 |
| `vllm` | PyPI | All versions | 0.32.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-115917?

Upgrade vllm to 0.32.0 or later.

## Is CVE-2026-115917 being exploited?

There is no known exploitation of CVE-2026-115917 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115917 and fix it if it is affected.

What it is: CVE-2026-115917 is a low-severity vulnerability in Vllm Vllm, published on 26 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115917 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.32.0
- vllm (PyPI): affected all versions; fixed in 0.32.0
- vllm (PyPI): affected all versions; fixed in 0.32.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115917/ (Markdown: https://insights.sbomify.com/CVE-2026-115917/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115917
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115917
- OSV: https://osv.dev/vulnerability/CVE-2026-115917

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115917/
Summaries are generated and may contain mistakes; the official description above is the record.
