CVE-2026-115918 vLLM: Responses API bypasses trust_request_chat_template for chat_template_kwargs

Medium 6.5 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-115918?

CVE-2026-115918 is a medium-severity vulnerability in Vllm Vllm, published on 26 Oct 2026.

Official description

vLLM is an inference and serving engine for large language models. From 0.16.0 until 0.32.0, the /v1/responses endpoint allows an authenticated caller to place an attacker-controlled template in chat_template_kwargs[chat_template] when no server template is configured. ChatParams.get_apply_chat_template_kwargs() preserves that value without enforcing trust_request_chat_template, so the request can bypass the intended trust policy and cause CPU or memory exhaustion through Jinja rendering. This issue is fixed in version 0.32.0.

Weakness: CWE-770, CWE-400

Which versions are affected by CVE-2026-115918?

3 open source packages ship an affected version, including vllm. It affects 1 product.

PackageAffectedFixed in
vllm PyPIFrom 0.16.00.32.0
vllm PyPIFrom 0.16.00.32.0
vllm PyPIFrom 0.16.00.32.0

Products include Vllm Vllm.

How do I fix CVE-2026-115918?

Upgrade vllm to 0.32.0 or later.

Is CVE-2026-115918 being exploited?

There is no known exploitation of CVE-2026-115918 in the wild and no public exploit code.

All Vllm Vllm vulnerabilities

Sources

Also known as GHSA-x567-49g5-p4cf, PYSEC-2026-4349.

Is CVE-2026-115918 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free