# CVE-2026-115919: ONNX: Out-of-Bounds Read in RNN/GRU/LSTM Shape Inference (Old Opsets, Missing Rank Check)


- **Severity:** Medium 6.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-115919, ECHO-2333-cd68-5267, GHSA-48m4-24cq-37qf, UBUNTU-CVE-2026-115919

## What is CVE-2026-115919?

CVE-2026-115919 is a medium-severity vulnerability in onnx, published on 26 Oct 2026. 

### Official description

Open Neural Network Exchange (ONNX) is an open standard for machine learning interoperability. Prior to 1.22.0, RNNShapeInference_opset1_to_6() processes malformed RNN and LSTM nodes from opsets 1 through 6 and GRU nodes from opsets 3 through 6 without verifying that the first input has rank three. The function accesses dim(0) and dim(1) on an undersized protobuf shape, which can read outside the intended repeated field and terminate an application when onnx.shape_inference.infer_shapes() processes an untrusted model that can pass onnx.checker.check_model(). This issue is fixed in version 1.22.0.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-115919?

2 open source packages ship an affected version, including onnx.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `onnx` | PyPI | All versions | 1.22.0 |
| `onnx` | PyPI | All versions | 1.22.0 |

## How do I fix CVE-2026-115919?

Upgrade onnx to 1.22.0 or later.

## Is CVE-2026-115919 being exploited?

There is no known exploitation of CVE-2026-115919 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115919 and fix it if it is affected.

What it is: CVE-2026-115919 is a medium-severity vulnerability in onnx, published on 26 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115919 in the wild and no public exploit code.

Affected packages and fixed versions:
- onnx (PyPI): affected all versions; fixed in 1.22.0
- onnx (PyPI): affected all versions; fixed in 1.22.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115919/ (Markdown: https://insights.sbomify.com/CVE-2026-115919/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115919
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115919
- OSV: https://osv.dev/vulnerability/CVE-2026-115919

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115919/
Summaries are generated and may contain mistakes; the official description above is the record.
