# CVE-2026-115922: ONNX: Denial of service via unchecked expansion of packed sub-byte tensors in ONNX Python APIs


- **Severity:** Medium 6.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-115922, ECHO-4a0c-5767-8d02, GHSA-q69g-f4f5-v8m7, UBUNTU-CVE-2026-115922

## What is CVE-2026-115922?

CVE-2026-115922 is a medium-severity vulnerability in onnx, published on 26 Oct 2026. 

### Official description

Open Neural Network Exchange (ONNX) is an open standard for machine learning interoperability. Prior to 1.22.0, _unpack_2bit() and _unpack_4bit() resize unpacked arrays according to attacker-controlled TensorProto.dims without verifying that raw_data or int32_data encodes the declared number of elements. Materializing an untrusted UINT2, INT2, UINT4, INT4, or FLOAT4E2M1 tensor through onnx.numpy_helper.to_array() or onnx.reference.ReferenceEvaluator can therefore expand a small packed payload into a disproportionately large allocation and exhaust memory. This issue is fixed in version 1.22.0.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2026-115922?

2 open source packages ship an affected version, including onnx.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `onnx` | PyPI | All versions | 1.22.0 |
| `onnx` | PyPI | All versions | 1.22.0 |

## How do I fix CVE-2026-115922?

Upgrade onnx to 1.22.0 or later.

## Is CVE-2026-115922 being exploited?

There is no known exploitation of CVE-2026-115922 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115922 and fix it if it is affected.

What it is: CVE-2026-115922 is a medium-severity vulnerability in onnx, published on 26 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115922 in the wild and no public exploit code.

Affected packages and fixed versions:
- onnx (PyPI): affected all versions; fixed in 1.22.0
- onnx (PyPI): affected all versions; fixed in 1.22.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115922/ (Markdown: https://insights.sbomify.com/CVE-2026-115922/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115922
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115922
- OSV: https://osv.dev/vulnerability/CVE-2026-115922

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115922/
Summaries are generated and may contain mistakes; the official description above is the record.
