{"answers":{"affected":"4 open source packages ship an affected version, including @backstage/plugin-catalog-backend.","exploited":"There is no known exploitation of CVE-2026-115923 in the wild and no public exploit code.","fix":"Upgrade @backstage/plugin-catalog-backend to a fixed version for your release line: 3.9.2 or 4.0.2.","what":"CVE-2026-115923 is a medium-severity vulnerability in backstage, published on 26 Oct 2026."},"fix_prompt":"Check this codebase for CVE-2026-115923 and fix it if it is affected.\n\nWhat it is: CVE-2026-115923 is a medium-severity vulnerability in backstage, published on 26 Oct 2026. \nExploitation: There is no known exploitation of CVE-2026-115923 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @backstage/plugin-catalog-backend (npm): affected all versions; fixed in 3.9.2\n- @backstage/plugin-catalog-backend (npm): affected all versions; fixed in 3.9.2\n- @backstage/plugin-catalog-backend (npm): affected from 4.0.0; fixed in 4.0.2\n- @backstage/plugin-catalog-backend (npm): affected from 4.0.0; fixed in 4.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-115923/ (Markdown: https://insights.sbomify.com/CVE-2026-115923/index.md)","id":"CVE-2026-115923","markdown":"https://insights.sbomify.com/CVE-2026-115923/index.md","name":"CVE-2026-115923","record":{"aliases":["GHSA-w658-mh9p-ww8f"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Backstage is an open framework for building developer portals. Prior to 3.9.2 and from 4.0.0 until 4.0.2, DefaultCatalogRulesEnforcer in @backstage/plugin-catalog-backend compares the raw location.target URL against catalog.rules, while URL readers canonicalize the same URL before fetching it. An authenticated user with catalog.location.create permission can use percent-encoded path segments to make an untrusted URL match a trusted location pattern even though the canonical URL resolves outside that scope. This admits entity content from an untrusted source as trusted, while further downstream consequences depend on deployment configuration. This issue is fixed in versions 3.9.2 and 4.0.2.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Backstage catalog rules can be bypassed for URL locations using encoded path segments","id":"CVE-2026-115923","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":null,"year":"2026"},"n_packages":4,"n_references":5,"next":{"headline":"Rembg: Unauthenticated SAM model injection permits local-file disclosure through malicious ONNX graphs","id":"CVE-2026-115924"},"packages":[{"ecosystem":"npm","fixed":["3.9.2"],"introduced":["0"],"last_affected":[],"package":"@backstage/plugin-catalog-backend","purl":null,"source":"GHSA-w658-mh9p-ww8f"},{"ecosystem":"npm","fixed":["3.9.2"],"introduced":["0"],"last_affected":[],"package":"@backstage/plugin-catalog-backend","purl":"pkg:npm/%40backstage/plugin-catalog-backend","source":"GHSA-w658-mh9p-ww8f"},{"ecosystem":"npm","fixed":["4.0.2"],"introduced":["4.0.0"],"last_affected":[],"package":"@backstage/plugin-catalog-backend","purl":null,"source":"GHSA-w658-mh9p-ww8f"},{"ecosystem":"npm","fixed":["4.0.2"],"introduced":["4.0.0"],"last_affected":[],"package":"@backstage/plugin-catalog-backend","purl":"pkg:npm/%40backstage/plugin-catalog-backend","source":"GHSA-w658-mh9p-ww8f"}],"prev":{"headline":"ONNX: Denial of service via unchecked expansion of packed sub-byte tensors in ONNX Python APIs","id":"CVE-2026-115922"},"products":["backstage"],"published":"2026-10-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2026-10-26","vendors":["backstage"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-115923/"}