# CVE-2026-115923: Backstage catalog rules can be bypassed for URL locations using encoded path segments


- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** GHSA-w658-mh9p-ww8f

## What is CVE-2026-115923?

CVE-2026-115923 is a medium-severity vulnerability in backstage, published on 26 Oct 2026. 

### Official description

Backstage is an open framework for building developer portals. Prior to 3.9.2 and from 4.0.0 until 4.0.2, DefaultCatalogRulesEnforcer in @backstage/plugin-catalog-backend compares the raw location.target URL against catalog.rules, while URL readers canonicalize the same URL before fetching it. An authenticated user with catalog.location.create permission can use percent-encoded path segments to make an untrusted URL match a trusted location pattern even though the canonical URL resolves outside that scope. This admits entity content from an untrusted source as trusted, while further downstream consequences depend on deployment configuration. This issue is fixed in versions 3.9.2 and 4.0.2.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-115923?

4 open source packages ship an affected version, including @backstage/plugin-catalog-backend.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-catalog-backend` | npm | All versions | 3.9.2 |
| `@backstage/plugin-catalog-backend` | npm | All versions | 3.9.2 |
| `@backstage/plugin-catalog-backend` | npm | From 4.0.0 | 4.0.2 |
| `@backstage/plugin-catalog-backend` | npm | From 4.0.0 | 4.0.2 |

## How do I fix CVE-2026-115923?

Upgrade @backstage/plugin-catalog-backend to a fixed version for your release line: 3.9.2 or 4.0.2.

## Is CVE-2026-115923 being exploited?

There is no known exploitation of CVE-2026-115923 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115923 and fix it if it is affected.

What it is: CVE-2026-115923 is a medium-severity vulnerability in backstage, published on 26 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115923 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-catalog-backend (npm): affected all versions; fixed in 3.9.2
- @backstage/plugin-catalog-backend (npm): affected all versions; fixed in 3.9.2
- @backstage/plugin-catalog-backend (npm): affected from 4.0.0; fixed in 4.0.2
- @backstage/plugin-catalog-backend (npm): affected from 4.0.0; fixed in 4.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115923/ (Markdown: https://insights.sbomify.com/CVE-2026-115923/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115923
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115923
- OSV: https://osv.dev/vulnerability/CVE-2026-115923

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115923/
Summaries are generated and may contain mistakes; the official description above is the record.
