CVE-2026-115930 MongoDB Shell (mongosh) bundled with Node.js trusts certificates issued by recoverable eMudhra intermediate CAs

High 7.6 Published Updated
Exploited in the wild
Not known
Fix
None listed

What is CVE-2026-115930?

CVE-2026-115930 is a high-severity vulnerability in MongoDB, Inc. mongosh, published on 26 Oct 2026.

Official description

The MongoDB Shell (mongosh) relies on Node.js as a third-party runtime that carries its own TLS root certificate store. This certificate store has the recoverable eMudhra intermediate CA certificates. This issue impacts MongoDB Shell (mongosh) versions prior to 2.14.0 and can be resolved by updating to mongosh 2.14.0 which bundles Node.js 24.22.1 or later. If mongosh is installed through npm, it uses the Node.js runtime installed on the host; update that runtime separately.

Weakness: CWE-295

Which versions are affected by CVE-2026-115930?

How do I fix CVE-2026-115930?

No fix has been published for CVE-2026-115930 yet. Limit exposure of the affected software until one is available.

Is CVE-2026-115930 being exploited?

There is no known exploitation of CVE-2026-115930 in the wild and no public exploit code.

Sources

Also known as GHSA-j35w-3h5p-45x6.

Is CVE-2026-115930 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free