CVE-2026-11607 TYPO3 CMS - Broken Access Control in Form Framework
Backend users can execute arbitrary SQL via malformed form files to create admin accounts, requiring immediate patching of TYPO3 CMS.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-11607?
CVE-2026-11607 is a high-severity missing authorization vulnerability in TYPO3 CMS, published on 9 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Backend users with access to the Form Framework were able to use files not ending in .form.yaml as form definitions, which were processed without denying the incorrect file extension. Maliciously crafted form definition files can be used to execute arbitrary SQL statements, allowing attackers to escalate privileges by creating administrative backend user accounts. This issue affects TYPO3 CMS versions before 10.4.57, 11.0.0-11.5.50, 12.0.0-12.4.45, 13.0.0-13.4.30 and 14.0.0-14.3.2.
Weakness: CWE-862
Which versions are affected by CVE-2026-11607?
20 open source packages ship an affected version, including typo3/cms-core and typo3/cms-form.
| Package | Affected | Fixed in |
|---|---|---|
typo3/cms-core Packagist | All versions | 10.4.57 |
typo3/cms-core Packagist | All versions | 10.4.57 |
typo3/cms-core Packagist | From 11.0.0 | 11.5.51 |
typo3/cms-core Packagist | From 11.0.0 | 11.5.51 |
typo3/cms-core Packagist | From 12.0.0 | 12.4.46 |
typo3/cms-core Packagist | From 12.0.0 | 12.4.46 |
14 more packages
typo3/cms-core Packagist | From 13.0.0 | 13.4.31 |
typo3/cms-core Packagist | From 13.0.0 | 13.4.31 |
typo3/cms-core Packagist | From 14.0.0 | 14.3.3 |
typo3/cms-core Packagist | From 14.0.0 | 14.3.3 |
typo3/cms-form Packagist | All versions | 10.4.57 |
typo3/cms-form Packagist | All versions | 10.4.57 |
typo3/cms-form Packagist | From 11.0.0 | 11.5.51 |
typo3/cms-form Packagist | From 11.0.0 | 11.5.51 |
typo3/cms-form Packagist | From 12.0.0 | 12.4.46 |
typo3/cms-form Packagist | From 12.0.0 | 12.4.46 |
typo3/cms-form Packagist | From 13.0.0 | 13.4.31 |
typo3/cms-form Packagist | From 13.0.0 | 13.4.31 |
typo3/cms-form Packagist | From 14.0.0 | 14.3.3 |
typo3/cms-form Packagist | From 14.0.0 | 14.3.3 |
How do I fix CVE-2026-11607?
Upgrade typo3/cms-core to a fixed version for your release line: 10.4.57, 11.5.51, 12.4.46 or 13.4.31.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-11607 being exploited?
There is no known exploitation of CVE-2026-11607 in the wild and no public exploit code.
Sources
Also known as GHSA-pjpj-v387-x4vq.