# CVE-2026-116176: vLLM 0.9.2 before 0.24.0 SSRF via X-Request-Id in P2pNcclConnector


- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 25 Oct 2026
- **Updated:** 25 Oct 2026
- **Also known as:** GHSA-3r8v-vh9c-f8hq, GHSA-vfp2-c8pq-v6h6, PYSEC-2026-4351

## What is CVE-2026-116176?

CVE-2026-116176 is a high-severity vulnerability in Vllm Vllm, published on 25 Oct 2026. 

### Official description

vLLM from 0.9.2 before 0.24.0 contains a server-side request forgery vulnerability that allows API callers to force outbound connections by embedding a decode address in the X-Request-Id header. Attackers can make a P2pNcclConnector prefill worker ZMQ-connect to an attacker host, leaking the NCCL unique_id and KV-cache tensors or blocking the worker.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-116176?

1 open source package ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.9.2 | 0.24.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-116176?

Upgrade vllm to 0.24.0 or later.

## Is CVE-2026-116176 being exploited?

There is no known exploitation of CVE-2026-116176 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-116176 and fix it if it is affected.

What it is: CVE-2026-116176 is a high-severity vulnerability in Vllm Vllm, published on 25 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-116176 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.9.2; fixed in 0.24.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-116176/ (Markdown: https://insights.sbomify.com/CVE-2026-116176/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-116176
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-116176
- OSV: https://osv.dev/vulnerability/CVE-2026-116176

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-116176/
Summaries are generated and may contain mistakes; the official description above is the record.
