# CVE-2026-116177: vLLM 0.10.2 before 0.25.0 DoS via Nemotron-VL Processor Decompression-Bomb Guard Bypass


- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 25 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-mm38-5g96-7j6x, GHSA-p9gm-63qh-x2pq, PYSEC-2026-4352

## What is CVE-2026-116177?

CVE-2026-116177 is a high-severity vulnerability in Vllm Vllm, published on 25 Oct 2026. 

### Official description

vLLM from 0.10.2 before 0.25.0 contains an uncontrolled resource consumption vulnerability that allows unauthenticated attackers to exhaust memory because the Nemotron-VL processors globally set Image.MAX_IMAGE_PIXELS to None. Attackers can submit a pathological decompression-bomb image to /v1/chat/completions to OOM-kill the worker and deny service to co-tenants.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-116177?

1 open source package ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.10.2 | 0.25.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-116177?

Upgrade vllm to 0.25.0 or later.

## Is CVE-2026-116177 being exploited?

There is no known exploitation of CVE-2026-116177 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-116177 and fix it if it is affected.

What it is: CVE-2026-116177 is a high-severity vulnerability in Vllm Vllm, published on 25 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-116177 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.10.2; fixed in 0.25.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-116177/ (Markdown: https://insights.sbomify.com/CVE-2026-116177/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-116177
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-116177
- OSV: https://osv.dev/vulnerability/CVE-2026-116177

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-116177/
Summaries are generated and may contain mistakes; the official description above is the record.
