{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-11623 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-11623 is a low-severity use after free vulnerability in tmux, published on 9 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-11623 and fix it if it is affected.\n\nWhat it is: CVE-2026-11623 is a low-severity use after free vulnerability in tmux, published on 9 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-11623 in the wild and no public exploit code.\n\nAffected product: tmux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-11623/ (Markdown: https://insights.sbomify.com/CVE-2026-11623/index.md)","id":"CVE-2026-11623","markdown":"https://insights.sbomify.com/CVE-2026-11623/index.md","name":"CVE-2026-11623","record":{"aliases":["AZL-90188","BELL-CVE-2026-11623","DEBIAN-CVE-2026-11623","ECHO-472d-c4a6-c1f9","GHSA-4cw9-jpqf-99x8","MGASA-2026-0255","UBUNTU-CVE-2026-11623","USN-8428-1","openSUSE-SU-2026:11006-1"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"terminal multiplexer","requires_auth":"low_privilege","summary":"A use-after-free flaw in tmux allows local attackers to potentially execute arbitrary code or escalate privileges via complex exploitation.","user_interaction":"not_required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":2,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-416","name":"Use After Free"},{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"A security vulnerability has been detected in tmux up to 3.6a. Affected is the function image_free of the file image.c. Such manipulation leads to use after free. Local access is required to approach this attack. This attack is characterized by high complexity. The exploitability is told to be difficult. The exploit has been disclosed publicly and may be used. Upgrading to version 3.7-rc is able to address this issue. The name of the patch is fc6d94a9f8a593bd8b7031650802084385d4ee03. The affected component should be upgraded.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"tmux image.c image_free use after free","id":"CVE-2026-11623","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"use_after_free","year":"2026"},"n_packages":1,"n_references":8,"next":{"headline":"MCP Toolbox for Databases has an Origin Validation Error","id":"CVE-2026-11624"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.6b-2.1"],"introduced":["0"],"last_affected":[],"package":"tmux","purl":"pkg:rpm/opensuse/tmux\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11006-1"}],"prev":{"headline":"Potential memory usage beyond configured limits","id":"CVE-2026-11622"},"products":["tmux"],"published":"2026-06-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-23","vendors":["n/a"]},"summary":"A use-after-free flaw in tmux allows local attackers to potentially execute arbitrary code or escalate privileges via complex exploitation.","url":"https://insights.sbomify.com/CVE-2026-11623/"}