# CVE-2026-11624: MCP Toolbox for Databases has an Origin Validation Error


- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 13 Jun 2026
- **Updated:** 15 Jun 2026
- **Also known as:** GHSA-76g7-m3xw-x9gr, GO-2026-6288

## What is CVE-2026-11624?

CVE-2026-11624 is a critical vulnerability in Google MCP Toolbox for Databases, published on 13 Jun 2026. 

### Official description

The Model Context Protocol has a security warning advising servers to validate the "Origin" header on all incoming connections to prevent DNS rebinding attacks. Prior to the v0.25.0 release, users had no way to validate the origin's host. In v0.25.0, a new "--allowed-hosts" flag was introduced alongside the existing "--allowed-origins" flag, enabling users to specify permitted hosts at server startup. Both flags default to "*", allowing users to implement strict access controls as needed without breaking existing setups. If either flag is set to "*", the server will output a startup warning about potential vulnerabilities. Documentation has also been updated to highlight these security considerations.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-11624?

3 open source packages ship an affected version, including github.com/googleapis/mcp-toolbox and github.com/googleapis/genai-toolbox.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/googleapis/mcp-toolbox` | Go | All versions | 0.25.0 |
| `github.com/googleapis/mcp-toolbox` | Go | All versions | 0.25.0 |
| `github.com/googleapis/genai-toolbox` | Go | All versions | 0.25.0 |

## How do I fix CVE-2026-11624?

Upgrade github.com/googleapis/mcp-toolbox to 0.25.0 or later.

## Is CVE-2026-11624 being exploited?

There is no known exploitation of CVE-2026-11624 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-11624 and fix it if it is affected.

What it is: CVE-2026-11624 is a critical vulnerability in Google MCP Toolbox for Databases, published on 13 Jun 2026. 
Exploitation: There is no known exploitation of CVE-2026-11624 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/googleapis/mcp-toolbox (Go): affected all versions; fixed in 0.25.0
- github.com/googleapis/mcp-toolbox (Go): affected all versions; fixed in 0.25.0
- github.com/googleapis/genai-toolbox (Go): affected all versions; fixed in 0.25.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-11624/ (Markdown: https://insights.sbomify.com/CVE-2026-11624/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-11624
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-11624
- OSV: https://osv.dev/vulnerability/CVE-2026-11624

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-11624/
Summaries are generated and may contain mistakes; the official description above is the record.
