# CVE-2026-116575: Mem0: Cross-tenant conversation leak via unescaped delimiter collision in session-scope key (_build_session_scope)


- **Severity:** Medium 6.3 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Oct 2026
- **Updated:** 27 Oct 2026
- **Also known as:** GHSA-5324-3w58-qpp2

## What is CVE-2026-116575?

CVE-2026-116575 is a medium-severity vulnerability in mem0ai mem0, published on 26 Oct 2026. 

### Official description

Mem0 provides persistent memory infrastructure for AI agents and applications. Prior to Python SDK 2.0.18 and TypeScript SDK 3.1.6, _build_session_scope() in mem0/memory/main.py and Memory.buildSessionScope() in the TypeScript SDK join caller-controlled user_id, agent_id, and run_id values using unescaped & and = delimiters. A caller can embed another scope component in a controlled identifier so that distinct tenant tuples produce the same session_scope key. Memory.add(), AsyncMemory.add(), and the REST POST /memories flow use that key to read and save recent raw messages, allowing cross-tenant conversation disclosure and eviction or interleaving of another tenant's history. This issue is fixed in Python SDK 2.0.18 and TypeScript SDK 3.1.6.

Weakness: CWE-863 (Incorrect Authorization), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-116575?

4 open source packages ship an affected version, including mem0ai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mem0ai` | PyPI | All versions | 2.0.18 |
| `mem0ai` | PyPI | All versions | 2.0.18 |
| `mem0ai` | npm | All versions | 3.1.6 |
| `mem0ai` | npm | All versions | 3.1.6 |

## How do I fix CVE-2026-116575?

Upgrade mem0ai to a fixed version for your release line: 2.0.18 or 3.1.6.

## Is CVE-2026-116575 being exploited?

There is no known exploitation of CVE-2026-116575 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-116575 and fix it if it is affected.

What it is: CVE-2026-116575 is a medium-severity vulnerability in mem0ai mem0, published on 26 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-116575 in the wild and no public exploit code.

Affected packages and fixed versions:
- mem0ai (PyPI): affected all versions; fixed in 2.0.18
- mem0ai (PyPI): affected all versions; fixed in 2.0.18
- mem0ai (npm): affected all versions; fixed in 3.1.6
- mem0ai (npm): affected all versions; fixed in 3.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-116575/ (Markdown: https://insights.sbomify.com/CVE-2026-116575/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-116575
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-116575
- OSV: https://osv.dev/vulnerability/CVE-2026-116575

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-116575/
Summaries are generated and may contain mistakes; the official description above is the record.
