# CVE-2026-116577: Tornado: Quadratic CPU usage when parsing HTTP headers with line folding


- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-116577, ECHO-02a2-2a6c-6e79, GHSA-pcg2-g6cj-q92c, MINI-4rr5-62fx-gqmp, UBUNTU-CVE-2026-116577

## What is CVE-2026-116577?

CVE-2026-116577 is a medium-severity vulnerability in tornadoweb tornado, published on 26 Oct 2026. 

### Official description

Tornado is a Python web framework and asynchronous networking library. Prior to 6.6, Tornado's HTTP header parser accepts obsolete line folding and repeatedly concatenates short continuation lines, causing quadratic CPU consumption on the IOLoop thread. An unauthenticated client can submit a header block containing many obsolete line-folding continuations before application code runs, blocking other connections served by the process. The cost grows with max_header_size, and only availability is affected. This issue is fixed in version 6.6.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2026-116577?

2 open source packages ship an affected version, including tornado.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tornado` | PyPI | All versions | 6.6 |
| `tornado` | PyPI | All versions | 6.6 |

## How do I fix CVE-2026-116577?

Upgrade tornado to 6.6 or later.

## Is CVE-2026-116577 being exploited?

There is no known exploitation of CVE-2026-116577 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-116577 and fix it if it is affected.

What it is: CVE-2026-116577 is a medium-severity vulnerability in tornadoweb tornado, published on 26 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-116577 in the wild and no public exploit code.

Affected packages and fixed versions:
- tornado (PyPI): affected all versions; fixed in 6.6
- tornado (PyPI): affected all versions; fixed in 6.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-116577/ (Markdown: https://insights.sbomify.com/CVE-2026-116577/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-116577
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-116577
- OSV: https://osv.dev/vulnerability/CVE-2026-116577

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-116577/
Summaries are generated and may contain mistakes; the official description above is the record.
