# CVE-2026-116579: Autobahn Python: permessage-brotli inflates a whole frame before maxMessagePayloadSize is checked (incomplete fix of GHSA-hxp9-w8x3-p566)


- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Oct 2026
- **Updated:** 27 Oct 2026
- **Also known as:** GHSA-pjh6-c8mg-3x7m, UBUNTU-CVE-2026-116579

## What is CVE-2026-116579?

CVE-2026-116579 is a medium-severity vulnerability in crossbario autobahn-python, published on 26 Oct 2026. 

### Official description

Autobahn Python is a WebSocket and WAMP implementation for Python that supports Twisted and asyncio. From 26.7.1 until 26.10.1, PerMessageBrotli.decompress_message_data in compress_brotli.py calls the Brotli decompressor without an output limit and checks maxMessagePayloadSize only after a complete frame has been inflated. An unauthenticated WebSocket client can send a small, highly compressed frame that allocates hundreds of MiB before rejection, causing memory-exhaustion denial of service on servers that enable the opt-in permessage-brotli feature through the compress extra. Deflate and bzip2 already enforce the remaining output budget and are outside this residual vulnerability. This issue is fixed in version 26.10.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2026-116579?

2 open source packages ship an affected version, including autobahn.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `autobahn` | PyPI | From 26.7.1 | 26.10.1 |
| `autobahn` | PyPI | From 26.7.1 | 26.10.1 |

## How do I fix CVE-2026-116579?

Upgrade autobahn to 26.10.1 or later.

## Is CVE-2026-116579 being exploited?

There is no known exploitation of CVE-2026-116579 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-116579 and fix it if it is affected.

What it is: CVE-2026-116579 is a medium-severity vulnerability in crossbario autobahn-python, published on 26 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-116579 in the wild and no public exploit code.

Affected packages and fixed versions:
- autobahn (PyPI): affected from 26.7.1; fixed in 26.10.1
- autobahn (PyPI): affected from 26.7.1; fixed in 26.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-116579/ (Markdown: https://insights.sbomify.com/CVE-2026-116579/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-116579
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-116579
- OSV: https://osv.dev/vulnerability/CVE-2026-116579

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-116579/
Summaries are generated and may contain mistakes; the official description above is the record.
