# CVE-2026-116581: Seroval: fromJSON deserializer trusts sequence doneAt (unauthenticated event-loop DoS)


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** GHSA-97r2-qh9m-474h

## What is CVE-2026-116581?

CVE-2026-116581 is a high-severity vulnerability in lxsmnsyc seroval, published on 26 Oct 2026. 

### Official description

Seroval facilitates JavaScript value stringification, including complex structures beyond JSON.stringify capabilities. Prior to 1.6.8, fromJSON and fromCrossJSON do not validate a sequence node's done index. A crafted done index can create an iterator that never finishes when application code consumes it to completion. An unauthenticated request to a service that deserializes untrusted input can therefore block the event loop, exhaust process memory, or make the service unavailable. This issue is fixed in version 1.6.8.

Weakness: CWE-835 (Loop with Unreachable Exit Condition), CWE-1284 (Improper Validation of Specified Quantity in Input)

## Which versions are affected by CVE-2026-116581?

2 open source packages ship an affected version, including seroval.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `seroval` | npm | All versions | 1.6.8 |
| `seroval` | npm | All versions | 1.6.8 |

## How do I fix CVE-2026-116581?

Upgrade seroval to 1.6.8 or later.

## Is CVE-2026-116581 being exploited?

There is no known exploitation of CVE-2026-116581 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-116581 and fix it if it is affected.

What it is: CVE-2026-116581 is a high-severity vulnerability in lxsmnsyc seroval, published on 26 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-116581 in the wild and no public exploit code.

Affected packages and fixed versions:
- seroval (npm): affected all versions; fixed in 1.6.8
- seroval (npm): affected all versions; fixed in 1.6.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-116581/ (Markdown: https://insights.sbomify.com/CVE-2026-116581/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-116581
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-116581
- OSV: https://osv.dev/vulnerability/CVE-2026-116581

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-116581/
Summaries are generated and may contain mistakes; the official description above is the record.
