# CVE-2026-116582: Seroval: Script injection through RegExp sources in serialized output


- **Severity:** Medium 4.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** GHSA-9wx9-5pv9-3349

## What is CVE-2026-116582?

CVE-2026-116582 is a medium-severity vulnerability in lxsmnsyc seroval, published on 26 Oct 2026. 

### Official description

Seroval facilitates JavaScript value stringification, including complex structures beyond JSON.stringify capabilities. Prior to 1.0.0 and from 1.5.5 until 1.6.10, the JavaScript-output APIs serialize a RegExp source containing a less-than character without the escaping needed for an HTML script element. An application is affected when it builds regular expression syntax from untrusted input, serializes that RegExp through serialize, serializeAsync, crossSerialize, crossSerializeAsync, crossSerializeStream, Serializer, or compileJSON, and embeds the result in an HTML script element. The crafted source can terminate the element and execute script in the page received by another user. This issue is fixed in version 1.6.10.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-116582?

4 open source packages ship an affected version, including seroval.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `seroval` | npm | All versions | 1.0.0 |
| `seroval` | npm | All versions | 1.0.0 |
| `seroval` | npm | From 1.5.5 | 1.6.10 |
| `seroval` | npm | From 1.5.5 | 1.6.10 |

## How do I fix CVE-2026-116582?

Upgrade seroval to a fixed version for your release line: 1.0.0 or 1.6.10.

## Is CVE-2026-116582 being exploited?

There is no known exploitation of CVE-2026-116582 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-116582 and fix it if it is affected.

What it is: CVE-2026-116582 is a medium-severity vulnerability in lxsmnsyc seroval, published on 26 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-116582 in the wild and no public exploit code.

Affected packages and fixed versions:
- seroval (npm): affected all versions; fixed in 1.0.0
- seroval (npm): affected all versions; fixed in 1.0.0
- seroval (npm): affected from 1.5.5; fixed in 1.6.10
- seroval (npm): affected from 1.5.5; fixed in 1.6.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-116582/ (Markdown: https://insights.sbomify.com/CVE-2026-116582/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-116582
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-116582
- OSV: https://osv.dev/vulnerability/CVE-2026-116582

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-116582/
Summaries are generated and may contain mistakes; the official description above is the record.
