# CVE-2026-116584: Seroval `fromJSON`/`fromCrossJSON` denial of service via unvalidated array node length


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** GHSA-wp97-x4hv-qvhp

## What is CVE-2026-116584?

CVE-2026-116584 is a high-severity vulnerability in lxsmnsyc seroval, published on 26 Oct 2026. 

### Official description

Seroval facilitates JavaScript value stringification, including complex structures beyond JSON.stringify capabilities. From 1.4.1 until 1.6.8, fromJSON and fromCrossJSON do not require an array node's element list to be an actual array. A small crafted payload can supply an attacker-controlled length that determines memory allocation and decoder iterations independently of payload size, allowing an unauthenticated request to exhaust the process or block its thread. This issue is a residual bypass of the remediation for CVE-2026-23957. This issue is fixed in version 1.6.8.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-116584?

2 open source packages ship an affected version, including seroval.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `seroval` | npm | From 1.4.1 | 1.6.8 |
| `seroval` | npm | From 1.4.1 | 1.6.8 |

## How do I fix CVE-2026-116584?

Upgrade seroval to 1.6.8 or later.

## Is CVE-2026-116584 being exploited?

There is no known exploitation of CVE-2026-116584 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-116584 and fix it if it is affected.

What it is: CVE-2026-116584 is a high-severity vulnerability in lxsmnsyc seroval, published on 26 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-116584 in the wild and no public exploit code.

Affected packages and fixed versions:
- seroval (npm): affected from 1.4.1; fixed in 1.6.8
- seroval (npm): affected from 1.4.1; fixed in 1.6.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-116584/ (Markdown: https://insights.sbomify.com/CVE-2026-116584/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-116584
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-116584
- OSV: https://osv.dev/vulnerability/CVE-2026-116584

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-116584/
Summaries are generated and may contain mistakes; the official description above is the record.
