# CVE-2026-116589: Datadog dd-trace-py: IAST instrumentation can lead to application DOS


- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** CLEANSTART-2026-ZH61936, GHSA-p3m5-h5v9-vqj6

## What is CVE-2026-116589?

CVE-2026-116589 is a high-severity vulnerability in DataDog dd-trace-py, published on 26 Oct 2026. 

### Official description

Datadog dd-trace-py is the Datadog Python APM client. From 3.13.0 until 4.15.5, the IAST string-processing instrumentation does not properly handle certain internal errors while old-style % string formatting processes attacker-controlled input. An unhandled error can terminate the Python process and interrupt the work it is handling. Exploitation requires IAST to be enabled, which is not the default, and application code to apply the affected formatting operation to attacker-controlled input. This issue is fixed in version 4.15.5.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-116589?

2 open source packages ship an affected version, including ddtrace.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ddtrace` | PyPI | From 3.13.0 | 4.15.5 |
| `ddtrace` | PyPI | From 3.13.0 | 4.15.5 |

## How do I fix CVE-2026-116589?

Upgrade ddtrace to 4.15.5 or later.

## Is CVE-2026-116589 being exploited?

There is no known exploitation of CVE-2026-116589 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-116589 and fix it if it is affected.

What it is: CVE-2026-116589 is a high-severity vulnerability in DataDog dd-trace-py, published on 26 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-116589 in the wild and no public exploit code.

Affected packages and fixed versions:
- ddtrace (PyPI): affected from 3.13.0; fixed in 4.15.5
- ddtrace (PyPI): affected from 3.13.0; fixed in 4.15.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-116589/ (Markdown: https://insights.sbomify.com/CVE-2026-116589/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-116589
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-116589
- OSV: https://osv.dev/vulnerability/CVE-2026-116589

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-116589/
Summaries are generated and may contain mistakes; the official description above is the record.
