# CVE-2026-116590: snappy-java: JVM crash from unchecked ranges in Snappy.arrayCopy and SnappyOutputStream.rawWrite


- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** ECHO-4010-d537-7ccd, GHSA-xqrx-qh46-34m7, UBUNTU-CVE-2026-116590

## What is CVE-2026-116590?

CVE-2026-116590 is a medium-severity vulnerability in xerial snappy-java, published on 26 Oct 2026. 

### Official description

snappy-java is a Java port of the snappy, a fast C++ compresser/decompresser developed by Google. Prior to 1.1.10.9, Snappy.arrayCopy(Object src, int offset, int byteLength, Object dest, int destOffset) passes caller-supplied ranges to native memcpy without validating either array, allowing negative or oversized byteLength and offset values to read or write outside array bounds and crash the JVM. SnappyOutputStream.rawWrite and SnappyInputStream.rawRead, including their typed-array write and read methods, pass caller-controlled ranges through this primitive, and typed-array byte-size calculations can overflow int. This issue is fixed in version 1.1.10.9.

Weakness: CWE-787 (Out-of-bounds Write), CWE-129 (Improper Validation of Array Index)

## Which versions are affected by CVE-2026-116590?

2 open source packages ship an affected version, including org.xerial.snappy:snappy-java.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xerial.snappy:snappy-java` | Maven | All versions | 1.1.10.9 |
| `org.xerial.snappy:snappy-java` | Maven | All versions | 1.1.10.9 |

## How do I fix CVE-2026-116590?

Upgrade org.xerial.snappy:snappy-java to 1.1.10.9 or later.

## Is CVE-2026-116590 being exploited?

There is no known exploitation of CVE-2026-116590 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-116590 and fix it if it is affected.

What it is: CVE-2026-116590 is a medium-severity vulnerability in xerial snappy-java, published on 26 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-116590 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xerial.snappy:snappy-java (Maven): affected all versions; fixed in 1.1.10.9
- org.xerial.snappy:snappy-java (Maven): affected all versions; fixed in 1.1.10.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-116590/ (Markdown: https://insights.sbomify.com/CVE-2026-116590/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-116590
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-116590
- OSV: https://osv.dev/vulnerability/CVE-2026-116590

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-116590/
Summaries are generated and may contain mistakes; the official description above is the record.
