CVE-2026-116593 Apache Kafka: Kafka Connect configuration provider values exposed via validation REST API endpoint

Not scored Published Updated
Exploited in the wild
Not known
Fix
None listed

What is CVE-2026-116593?

CVE-2026-116593 is a vulnerability in Apache Kafka, published on 28 Oct 2026.

Official description

Apache Kafka Connect has the /connector-plugins/{connector-type}/config/validate endpoint on its REST API to validate connector configurations. Apache Kafka Connect also support Configuration Providers which enable to hide the values of sensitive configuration and only resolve them at runtime. 

An attacker with access to the validate endpoint can use it to resolve and return plaintext values via any of the configuration providers installed on a Connect worker.

Users are recommended to upgrade to version 4.2.2, 4.3.2, 4.4.0 or above, which fix this issue.

Which versions are affected by CVE-2026-116593?

How do I fix CVE-2026-116593?

No fix has been published for CVE-2026-116593 yet. Limit exposure of the affected software until one is available.

Is CVE-2026-116593 being exploited?

There is no known exploitation of CVE-2026-116593 in the wild and no public exploit code.

Sources

Also known as GHSA-mf84-q3cw-6ch9.

Is CVE-2026-116593 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free