# CVE-2026-116690: MLflow: Arbitrary file read on unauthenticated MLflow servers via prompt model version source


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 27 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** GHSA-m65p-9j7q-6w33

## What is CVE-2026-116690?

CVE-2026-116690 is a high-severity vulnerability in mlflow, published on 27 Oct 2026. 

### Official description

MLflow is an open source AI engineering platform for agents, large language models, and machine learning models. From 3.10.0 until 3.17.0, the prompt branch in _create_model_version() accepts schemeless relative sources because path validation runs only when a source has a URL scheme, and mlflow.prompt.is_prompt is interpreted by tag presence rather than a true value. A remote caller can store a server-local path as the model version artifact location and use /api/2.0/mlflow/model-versions/get-artifact to read files accessible to the MLflow server process. Default unauthenticated servers require no privileges, while basic-auth deployments are exposed to authenticated users who can create registered models. This issue is fixed in version 3.17.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-116690?

2 open source packages ship an affected version, including mlflow.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | PyPI | From 3.10.0 | 3.17.0 |
| `mlflow` | PyPI | From 3.10.0 | 3.17.0 |

## How do I fix CVE-2026-116690?

Upgrade mlflow to 3.17.0 or later.

## Is CVE-2026-116690 being exploited?

There is no known exploitation of CVE-2026-116690 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-116690 and fix it if it is affected.

What it is: CVE-2026-116690 is a high-severity vulnerability in mlflow, published on 27 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-116690 in the wild and no public exploit code.

Affected packages and fixed versions:
- mlflow (PyPI): affected from 3.10.0; fixed in 3.17.0
- mlflow (PyPI): affected from 3.10.0; fixed in 3.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-116690/ (Markdown: https://insights.sbomify.com/CVE-2026-116690/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-116690
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-116690
- OSV: https://osv.dev/vulnerability/CVE-2026-116690

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-116690/
Summaries are generated and may contain mistakes; the official description above is the record.
