CVE-2026-116692 MLflow vulnerable to remote code execution on unauthenticated servers via third-party scorer deserialization importing caller-placed artifact modules
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2026-116692?
CVE-2026-116692 is a critical vulnerability in mlflow, published on 27 Oct 2026.
Official description
MLflow is an open source AI engineering platform for agents, large language models, and machine learning models. From 3.12.0rc0 until 3.17.0, third-party scorer deserialization in mlflow/genai/scorers/base.py accepts request-selected descendants of THIRD_PARTY_SCORER_ALLOWED_MODULES rather than requiring an exact allowed module. A caller can use MLflow artifact endpoints to place a Python module beneath a writable allowed package and submit its module and class through /ajax-api/3.0/mlflow/scorer/invoke. Scorer.model_validate_json() imports the module and constructs the class before trace processing. Authentication-disabled deployments permit this code execution without credentials, while basic-auth deployments require a principal capable of creating an experiment and run and uploading artifacts. In either configuration, the allowed scorer package must be writable by the server process. This issue is fixed in version 3.17.0.
Which versions are affected by CVE-2026-116692?
2 open source packages ship an affected version, including mlflow.
| Package | Affected | Fixed in |
|---|---|---|
mlflow PyPI | From 3.12.0rc0 | 3.17.0 |
mlflow PyPI | From 3.12.0rc0 | 3.17.0 |
How do I fix CVE-2026-116692?
Upgrade mlflow to 3.17.0 or later.
Is CVE-2026-116692 being exploited?
There is no known exploitation of CVE-2026-116692 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Sources
Also known as GHSA-26p8-2jq9-3vq9.