# CVE-2026-116692: MLflow vulnerable to remote code execution on unauthenticated servers via third-party scorer deserialization importing caller-placed artifact modules


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 27 Oct 2026
- **Updated:** 27 Oct 2026
- **Also known as:** GHSA-26p8-2jq9-3vq9

## What is CVE-2026-116692?

CVE-2026-116692 is a critical vulnerability in mlflow, published on 27 Oct 2026. 

### Official description

MLflow is an open source AI engineering platform for agents, large language models, and machine learning models. From 3.12.0rc0 until 3.17.0, third-party scorer deserialization in mlflow/genai/scorers/base.py accepts request-selected descendants of THIRD_PARTY_SCORER_ALLOWED_MODULES rather than requiring an exact allowed module. A caller can use MLflow artifact endpoints to place a Python module beneath a writable allowed package and submit its module and class through /ajax-api/3.0/mlflow/scorer/invoke. Scorer.model_validate_json() imports the module and constructs the class before trace processing. Authentication-disabled deployments permit this code execution without credentials, while basic-auth deployments require a principal capable of creating an experiment and run and uploading artifacts. In either configuration, the allowed scorer package must be writable by the server process. This issue is fixed in version 3.17.0.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-470 (Use of Externally-Controlled Input to Select Classes or Code)

## Which versions are affected by CVE-2026-116692?

2 open source packages ship an affected version, including mlflow.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | PyPI | From 3.12.0rc0 | 3.17.0 |
| `mlflow` | PyPI | From 3.12.0rc0 | 3.17.0 |

## How do I fix CVE-2026-116692?

Upgrade mlflow to 3.17.0 or later.

## Is CVE-2026-116692 being exploited?

There is no known exploitation of CVE-2026-116692 in the wild and no public exploit code.

Public exploit code:

- Detection-only triage scanner for MLflow scorer RCE CVE-2026-116692: version check via the /version endpoint. No payloads, no scorer invocation. (github_poc): https://github.com/foxcornlab/mlflow-scorer-scanner

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-116692 and fix it if it is affected.

What it is: CVE-2026-116692 is a critical vulnerability in mlflow, published on 27 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-116692 in the wild and no public exploit code.

Affected packages and fixed versions:
- mlflow (PyPI): affected from 3.12.0rc0; fixed in 3.17.0
- mlflow (PyPI): affected from 3.12.0rc0; fixed in 3.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-116692/ (Markdown: https://insights.sbomify.com/CVE-2026-116692/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-116692
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-116692
- OSV: https://osv.dev/vulnerability/CVE-2026-116692

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-116692/
Summaries are generated and may contain mistakes; the official description above is the record.
