# CVE-2026-116694: OpenTelemetry Python: Unbounded memory allocation in Jaeger baggage propagation


- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 27 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-116694, GHSA-f5m9-jfrj-jjj7, UBUNTU-CVE-2026-116694

## What is CVE-2026-116694?

CVE-2026-116694 is a medium-severity vulnerability in open-telemetry opentelemetry-python, published on 27 Oct 2026. 

### Official description

OpenTelemetry Python provides the Python API and SDK for OpenTelemetry. Prior to 1.45.0, JaegerPropagator.extract() in opentelemetry-propagator-jaeger processes inbound uberctx-* baggage values without entry, per-entry byte, or total-byte limits. Services that enable the optional Jaeger propagator can perform unnecessary CPU work and short-lived heap allocations when an untrusted carrier supplies numerous or oversized values, contributing to denial of service when transport-level limits do not constrain the input. Common default Python HTTP server limits reduce the practical impact, while custom getters, non-HTTP transports, or raised header limits increase exposure. This issue is fixed in version 1.45.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-116694?

2 open source packages ship an affected version, including opentelemetry-propagator-jaeger.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `opentelemetry-propagator-jaeger` | PyPI | All versions | 1.45.0 |
| `opentelemetry-propagator-jaeger` | PyPI | All versions | 1.45.0 |

## How do I fix CVE-2026-116694?

Upgrade opentelemetry-propagator-jaeger to 1.45.0 or later.

## Is CVE-2026-116694 being exploited?

There is no known exploitation of CVE-2026-116694 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-116694 and fix it if it is affected.

What it is: CVE-2026-116694 is a medium-severity vulnerability in open-telemetry opentelemetry-python, published on 27 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-116694 in the wild and no public exploit code.

Affected packages and fixed versions:
- opentelemetry-propagator-jaeger (PyPI): affected all versions; fixed in 1.45.0
- opentelemetry-propagator-jaeger (PyPI): affected all versions; fixed in 1.45.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-116694/ (Markdown: https://insights.sbomify.com/CVE-2026-116694/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-116694
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-116694
- OSV: https://osv.dev/vulnerability/CVE-2026-116694

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-116694/
Summaries are generated and may contain mistakes; the official description above is the record.
