# CVE-2026-116695: Crass: Incorrect tokenization of bad URLs enables CSS sanitizer bypass


- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 27 Oct 2026
- **Updated:** 27 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-116695, GHSA-pq4g-8rxf-4g29, UBUNTU-CVE-2026-116695

## What is CVE-2026-116695?

CVE-2026-116695 is a medium-severity vulnerability in rgrove crass, published on 27 Oct 2026. 

### Official description

Crass is a Ruby CSS parser that is compliant with the CSS Syntax Level 3 specification. Prior to 1.0.8, Crass incorrectly treats a closing parenthesis after an escaped backslash as escaped while consuming the remnants of a bad URL. Crass therefore keeps declarations, style rules, or at-rules inside a bad URL token even though a browser treats them as live CSS. A sanitizer that parses untrusted CSS with Crass and reserializes it without rejecting the bad URL can allow CSS used for UI redress, external resource loading, or CSS-based data exfiltration, but this issue does not enable script execution in modern browsers. This issue is fixed in version 1.0.8.

Weakness: CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2026-116695?

2 open source packages ship an affected version, including crass.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `crass` | RubyGems | All versions | 1.0.8 |
| `crass` | RubyGems | All versions | 1.0.8 |

## How do I fix CVE-2026-116695?

Upgrade crass to 1.0.8 or later.

## Is CVE-2026-116695 being exploited?

There is no known exploitation of CVE-2026-116695 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-116695 and fix it if it is affected.

What it is: CVE-2026-116695 is a medium-severity vulnerability in rgrove crass, published on 27 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-116695 in the wild and no public exploit code.

Affected packages and fixed versions:
- crass (RubyGems): affected all versions; fixed in 1.0.8
- crass (RubyGems): affected all versions; fixed in 1.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-116695/ (Markdown: https://insights.sbomify.com/CVE-2026-116695/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-116695
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-116695
- OSV: https://osv.dev/vulnerability/CVE-2026-116695

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-116695/
Summaries are generated and may contain mistakes; the official description above is the record.
