# CVE-2026-116773: russh's SSH client is susceptible to unbounded allocations via EXT_INFO packets


- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 27 Oct 2026
- **Updated:** 27 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-116773, GHSA-4p9f-7p9m-5vfg, UBUNTU-CVE-2026-116773

## What is CVE-2026-116773?

CVE-2026-116773 is a medium-severity vulnerability in Eugeny russh, published on 27 Oct 2026. 

### Official description

russh is a Rust SSH client and server library that includes an SSH agent protocol implementation. Prior to 0.65.0, the client Session::process_packet path in russh/src/client/encrypted.rs accepts repeated packets encoded with russh's private msg::EXT_INFO = 7 before authentication, while the standards-compliant EXT_INFO message number 82 does not reach the affected handler. The handle_ext_info function appends every parsed extension name to received_extensions without clearing, deduplicating, or bounding the vector. A malicious SSH server that deliberately sends private message number 7 can therefore retain an unbounded number of attacker-controlled extension names for the session lifetime, causing progressive client memory exhaustion. This issue is fixed in version 0.65.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-116773?


## How do I fix CVE-2026-116773?

No fix has been published for CVE-2026-116773 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-116773 being exploited?

There is no known exploitation of CVE-2026-116773 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-116773 and fix it if it is affected.

What it is: CVE-2026-116773 is a medium-severity vulnerability in Eugeny russh, published on 27 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-116773 in the wild and no public exploit code.

Affected product: Eugeny russh. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-116773/ (Markdown: https://insights.sbomify.com/CVE-2026-116773/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-116773
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-116773
- OSV: https://osv.dev/vulnerability/CVE-2026-116773

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-116773/
Summaries are generated and may contain mistakes; the official description above is the record.
