# CVE-2026-116778: FOG: Authenticated low-privileged API user can modify Storage Nodes and reach root command execution


- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 28 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** GHSA-2hqx-5ffg-w4c3

## What is CVE-2026-116778?

CVE-2026-116778 is a high-severity vulnerability in fogproject, published on 28 Oct 2026. 

### Official description

FOG is a free open-source cloning/imaging/rescue suite/inventory management system. Prior to 1.5.10.2253 and 1.6.0-RC-1, an authenticated API-enabled user with uType=1 who possesses both the user's API token and the global FOG API token can use PUT /fog/storagenode/{id}/edit to modify Storage Node user, pass, and ftppath fields because the API validates the credentials but does not enforce an administrator-only role. With storage replication enabled and a usable Storage Node, FOGImageReplicator interpolates those fields into an lftp command executed through proc_open() by the root-running service, allowing the low-privileged user to execute commands as root. This issue is fixed in versions 1.5.10.2253 and 1.6.0-RC-1.

Weakness: CWE-862 (Missing Authorization), CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-116778?


## How do I fix CVE-2026-116778?

No fix has been published for CVE-2026-116778 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-116778 being exploited?

There is no known exploitation of CVE-2026-116778 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-116778 and fix it if it is affected.

What it is: CVE-2026-116778 is a high-severity vulnerability in fogproject, published on 28 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-116778 in the wild and no public exploit code.

Affected product: fogproject. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-116778/ (Markdown: https://insights.sbomify.com/CVE-2026-116778/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-116778
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-116778
- OSV: https://osv.dev/vulnerability/CVE-2026-116778

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-116778/
Summaries are generated and may contain mistakes; the official description above is the record.
