CVE-2026-116797 Highcharts Grid Pro: cell-renderer `attributes` map written with raw `setAttribute`
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2026-116797?
CVE-2026-116797 is a high-severity vulnerability in @highcharts dashboards, published on 28 Oct 2026.
Official description
Highcharts JS is a JavaScript charting library based on SVG. From 2.0.0 until 3.2.0, Highcharts Grid Pro input renderers copy the cells.renderer.attributes and cells.editMode.renderer.attributes maps to input or select elements with raw setAttribute calls. An attacker who controls column configuration can add event-handler attributes to every rendered row or to the control created when a cell enters edit mode. Script then runs in the hosting page origin when a user hovers over or focuses an input or begins editing. This issue is fixed in Grid Pro 3.2.0.
Weakness: CWE-79
Which versions are affected by CVE-2026-116797?
4 open source packages ship an affected version, including @highcharts/dashboards and @highcharts/grid-pro.
| Package | Affected | Fixed in |
|---|---|---|
@highcharts/dashboards npm | From 3.6.0 | 4.0.0 |
@highcharts/dashboards npm | From 3.6.0 | 4.0.0 |
@highcharts/grid-pro npm | From 2.0.0 | 3.2.0 |
@highcharts/grid-pro npm | From 2.0.0 | 3.2.0 |
How do I fix CVE-2026-116797?
Upgrade @highcharts/dashboards to 4.0.0 or later.
Is CVE-2026-116797 being exploited?
There is no known exploitation of CVE-2026-116797 in the wild and no public exploit code.
Sources
Also known as GHSA-5ghw-9mgr-jvx2.