# CVE-2026-116797: Highcharts Grid Pro: cell-renderer `attributes` map written with raw `setAttribute`


- **Severity:** High 8.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 28 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** GHSA-5ghw-9mgr-jvx2

## What is CVE-2026-116797?

CVE-2026-116797 is a high-severity vulnerability in @highcharts dashboards, published on 28 Oct 2026. 

### Official description

Highcharts JS is a JavaScript charting library based on SVG. From 2.0.0 until 3.2.0, Highcharts Grid Pro input renderers copy the cells.renderer.attributes and cells.editMode.renderer.attributes maps to input or select elements with raw setAttribute calls. An attacker who controls column configuration can add event-handler attributes to every rendered row or to the control created when a cell enters edit mode. Script then runs in the hosting page origin when a user hovers over or focuses an input or begins editing. This issue is fixed in Grid Pro 3.2.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-116797?

4 open source packages ship an affected version, including @highcharts/dashboards and @highcharts/grid-pro.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@highcharts/dashboards` | npm | From 3.6.0 | 4.0.0 |
| `@highcharts/dashboards` | npm | From 3.6.0 | 4.0.0 |
| `@highcharts/grid-pro` | npm | From 2.0.0 | 3.2.0 |
| `@highcharts/grid-pro` | npm | From 2.0.0 | 3.2.0 |

## How do I fix CVE-2026-116797?

Upgrade @highcharts/dashboards to 4.0.0 or later.

## Is CVE-2026-116797 being exploited?

There is no known exploitation of CVE-2026-116797 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-116797 and fix it if it is affected.

What it is: CVE-2026-116797 is a high-severity vulnerability in @highcharts dashboards, published on 28 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-116797 in the wild and no public exploit code.

Affected packages and fixed versions:
- @highcharts/dashboards (npm): affected from 3.6.0; fixed in 4.0.0
- @highcharts/dashboards (npm): affected from 3.6.0; fixed in 4.0.0
- @highcharts/grid-pro (npm): affected from 2.0.0; fixed in 3.2.0
- @highcharts/grid-pro (npm): affected from 2.0.0; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-116797/ (Markdown: https://insights.sbomify.com/CVE-2026-116797/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-116797
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-116797
- OSV: https://osv.dev/vulnerability/CVE-2026-116797

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-116797/
Summaries are generated and may contain mistakes; the official description above is the record.
