# CVE-2026-116890: Semantic MediaWiki 3.0.0 before 7.3.0 Missing Authorization via smwtask API


- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 27 Oct 2026
- **Updated:** 27 Oct 2026
- **Also known as:** GHSA-4cv4-rp7r-qh6c, GHSA-jr78-w6w5-m8f8

## What is CVE-2026-116890?

CVE-2026-116890 is a medium-severity vulnerability in SemanticMediaWiki, published on 27 Oct 2026. 

### Official description

Semantic MediaWiki from 3.0.0 before 7.3.0 contains a missing authorization vulnerability in the api.php smwtask module that allows unauthenticated attackers to run admin-only maintenance tasks. Attackers can use the public anonymous CSRF token to read internal store statistics, enqueue jobs like smw.entityIdDisposer, and execute queued jobs, degrading performance and altering semantic data.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-116890?

2 open source packages ship an affected version, including mediawiki/semantic-media-wiki.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki/semantic-media-wiki` | Packagist | From 3.0.0 | 7.3.0 |
| `mediawiki/semantic-media-wiki` | Packagist | From 3.0.0 | 7.3.0 |

## How do I fix CVE-2026-116890?

Upgrade mediawiki/semantic-media-wiki to 7.3.0 or later.

## Is CVE-2026-116890 being exploited?

There is no known exploitation of CVE-2026-116890 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-116890 and fix it if it is affected.

What it is: CVE-2026-116890 is a medium-severity vulnerability in SemanticMediaWiki, published on 27 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-116890 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki/semantic-media-wiki (Packagist): affected from 3.0.0; fixed in 7.3.0
- mediawiki/semantic-media-wiki (Packagist): affected from 3.0.0; fixed in 7.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-116890/ (Markdown: https://insights.sbomify.com/CVE-2026-116890/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-116890
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-116890
- OSV: https://osv.dev/vulnerability/CVE-2026-116890

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-116890/
Summaries are generated and may contain mistakes; the official description above is the record.
