# CVE-2026-11718: googleapis/mcp-toolbox: authentication bypass vulnerability in the generic opaque token validation path (validateOpaqueToken)

> Attackers can bypass authentication by using tokens from unauthorized identity providers due to missing issuer validation in the MCP Toolbox library.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jun 2026
- **Updated:** 18 Jun 2026
- **Also known as:** GHSA-wcpr-6g7x-p44r, GO-2026-5706

## What is CVE-2026-11718?

CVE-2026-11718 is a critical authentication bypass vulnerability in MCP Toolbox for Databases (googleapis/mcp-toolbox), published on 18 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An authentication bypass vulnerability exists in the generic opaque token validation path (validateOpaqueToken) of googleapis/mcp-toolbox.

When the toolbox validates an opaque token via an OAuth 2.0 introspection endpoint (RFC 7662), it decodes the response into an introspectResp struct. However, the subsequent claim-checking logic (validateClaims) evaluates the issuer condition as if a.issuer != "" && iss != "". If the external OAuth provider's introspection response omits the optional iss (issuer) field completely, the variable iss defaults to an empty string. This causes the conditional block to evaluate to false and be skipped silently. Consequently, the application accepts tokens issued by unauthorized or unintended third-party identity providers.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-11718?

3 open source packages ship an affected version, including github.com/googleapis/mcp-toolbox. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/googleapis/mcp-toolbox` | Go | All versions | 1.4.0 |
| `github.com/googleapis/mcp-toolbox` | Go | All versions | 1.4.0 |
| `github.com/googleapis/mcp-toolbox` | Go | All versions | 1.4.0 |

Products: Google Mcp Toolbox for Databases.

## How do I fix CVE-2026-11718?

Upgrade github.com/googleapis/mcp-toolbox to 1.4.0 or later.

## Is CVE-2026-11718 being exploited?

There is no known exploitation of CVE-2026-11718 in the wild and no public exploit code.

## Other vulnerabilities in MCP Toolbox for Databases (googleapis/mcp-toolbox)

- [CVE-2026-11720](https://insights.sbomify.com/CVE-2026-11720/): Path Traversal in googleapis/mcp-toolbox HTTP Tool URL Builder (critical 9.3)
- [CVE-2026-11717](https://insights.sbomify.com/CVE-2026-11717/): googleapis/mcp-toolbox: authentication bypass vulnerability in the generic opaque token validation path (validateOpaqueToken) (critical 9.3)
- [CVE-2026-15829](https://insights.sbomify.com/CVE-2026-15829/): SQL Injection and Security Boundary Bypass in googleapis/mcp-toolbox (high 8.6)
- [CVE-2026-11719](https://insights.sbomify.com/CVE-2026-11719/): MCP Toolbox for Databases: authenticated authorization bypass (high 8.6)
- [CVE-2026-14537](https://insights.sbomify.com/CVE-2026-14537/): Authorization Bypass in MCP Toolbox Legacy HTTP Endpoints (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-11718 and fix it if it is affected.

What it is: CVE-2026-11718 is a critical authentication bypass vulnerability in MCP Toolbox for Databases (googleapis/mcp-toolbox), published on 18 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-11718 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/googleapis/mcp-toolbox (Go): affected all versions; fixed in 1.4.0
- github.com/googleapis/mcp-toolbox (Go): affected all versions; fixed in 1.4.0
- github.com/googleapis/mcp-toolbox (Go): affected all versions; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-11718/ (Markdown: https://insights.sbomify.com/CVE-2026-11718/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-11718
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-11718
- OSV: https://osv.dev/vulnerability/CVE-2026-11718

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-11718/
Summaries are generated and may contain mistakes; the official description above is the record.
