# CVE-2026-11719: MCP Toolbox for Databases: authenticated authorization bypass

> Authenticated low-privilege users can bypass scope restrictions and execute high-privilege tools by using older protocol versions in MCP Toolbox for Databases.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jun 2026
- **Updated:** 18 Jun 2026
- **Also known as:** GHSA-5gf6-gc35-xjpc, GO-2026-5144

## What is CVE-2026-11719?

CVE-2026-11719 is a high-severity missing authorization vulnerability in MCP Toolbox for Databases (googleapis/mcp-toolbox), published on 18 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An authenticated authorization bypass vulnerability exists in MCP Toolbox for Databases due to missing scope enforcement across older protocol handlers.

While the 2025-11-25 protocol version handler correctly enforces per-tool restrictions defined by scopesRequired, older supported protocol versions (2025-06-18, 2025-03-26, and 2024-11-05) omit this check. An authenticated client with low-privilege tokens (e.g., read) can bypass the intended per-tool scope restrictions and execute high-privilege tools (e.g., admin) simply by specifying an older protocol version in the MCP-Protocol-Version header, or by omitting the header entirely (which causes the server to default to the vulnerable 2024-11-05 handler).

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-11719?

3 open source packages ship an affected version, including github.com/googleapis/mcp-toolbox. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/googleapis/mcp-toolbox` | Go | All versions | 1.4.0 |
| `github.com/googleapis/mcp-toolbox` | Go | All versions | 1.4.0 |
| `github.com/googleapis/mcp-toolbox` | Go | All versions | 1.4.0 |

Products: Google Mcp Toolbox for Databases.

## How do I fix CVE-2026-11719?

Upgrade github.com/googleapis/mcp-toolbox to 1.4.0 or later.

## Is CVE-2026-11719 being exploited?

There is no known exploitation of CVE-2026-11719 in the wild and no public exploit code.

## Other vulnerabilities in MCP Toolbox for Databases (googleapis/mcp-toolbox)

- [CVE-2026-11720](https://insights.sbomify.com/CVE-2026-11720/): Path Traversal in googleapis/mcp-toolbox HTTP Tool URL Builder (critical 9.3)
- [CVE-2026-11717](https://insights.sbomify.com/CVE-2026-11717/): googleapis/mcp-toolbox: authentication bypass vulnerability in the generic opaque token validation path (validateOpaqueToken) (critical 9.3)
- [CVE-2026-11718](https://insights.sbomify.com/CVE-2026-11718/): googleapis/mcp-toolbox: authentication bypass vulnerability in the generic opaque token validation path (validateOpaqueToken) (critical 9.3)
- [CVE-2026-15829](https://insights.sbomify.com/CVE-2026-15829/): SQL Injection and Security Boundary Bypass in googleapis/mcp-toolbox (high 8.6)
- [CVE-2026-14537](https://insights.sbomify.com/CVE-2026-14537/): Authorization Bypass in MCP Toolbox Legacy HTTP Endpoints (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-11719 and fix it if it is affected.

What it is: CVE-2026-11719 is a high-severity missing authorization vulnerability in MCP Toolbox for Databases (googleapis/mcp-toolbox), published on 18 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-11719 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/googleapis/mcp-toolbox (Go): affected all versions; fixed in 1.4.0
- github.com/googleapis/mcp-toolbox (Go): affected all versions; fixed in 1.4.0
- github.com/googleapis/mcp-toolbox (Go): affected all versions; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-11719/ (Markdown: https://insights.sbomify.com/CVE-2026-11719/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-11719
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-11719
- OSV: https://osv.dev/vulnerability/CVE-2026-11719

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-11719/
Summaries are generated and may contain mistakes; the official description above is the record.
