# CVE-2026-11746: Central Dogma: Hard-coded ZooKeeper replication secret 'ch4n63m3' with silent fallback enables cluster takeover

> Enabling ZooKeeper replication without a secret uses a hardcoded credential, allowing attackers to read logs or execute commands.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** GHSA-2j95-gqxf-v3vg

## What is CVE-2026-11746?

CVE-2026-11746 is a critical vulnerability in LY Corporation Central Dogma, published on 22 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability has been identified in centraldogma-server versions prior to 0.84.0, where enabling ZooKeeper replication without setting replication.secret causes the server to silently fall back to a hard-coded, publicly known secret. This default credential authenticates the embedded ZooKeeper ensemble, allowing an attacker with network access to read the full replication log or join the quorum and execute arbitrary replicated commands across the cluster.

Weakness: CWE-798 (Use of Hard-coded Credentials)

## Which versions are affected by CVE-2026-11746?

2 open source packages ship an affected version, including com.linecorp.centraldogma:centraldogma-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.linecorp.centraldogma:centraldogma-server` | Maven | All versions | 0.84.0 |
| `com.linecorp.centraldogma:centraldogma-server` | Maven | All versions | 0.84.0 |

## How do I fix CVE-2026-11746?

Upgrade com.linecorp.centraldogma:centraldogma-server to 0.84.0 or later.

## Is CVE-2026-11746 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-11746 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-11746 and fix it if it is affected.

What it is: CVE-2026-11746 is a critical vulnerability in LY Corporation Central Dogma, published on 22 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-11746 exists.

Affected packages and fixed versions:
- com.linecorp.centraldogma:centraldogma-server (Maven): affected all versions; fixed in 0.84.0
- com.linecorp.centraldogma:centraldogma-server (Maven): affected all versions; fixed in 0.84.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-11746/ (Markdown: https://insights.sbomify.com/CVE-2026-11746/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-11746
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-11746
- OSV: https://osv.dev/vulnerability/CVE-2026-11746

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-11746/
Summaries are generated and may contain mistakes; the official description above is the record.
